God of War Community
27 Aug 2017 03:38 PM
By: Blackspawn89

icon_email Send Message

God of War Origins Collection Question

4 replies

I have tried 2 different PS4 controllers on my PS3 to try and play Chains of Olympus and it simply does not get past the picture resize option. I can somehow move the screen left and right and can adjust it but it does not register the X button command at all. Does this game not work with a Dualshock 4 controller because everything I have seen on the website says it does.

Are you simply forced to use a Dualshock 3 to play this? I have tried both wirelessly and hooked to the charging USB cable to the PS3 to try and play this. GOW 1 HD works just fine with the controller. 

Shame Origins collection isn't PS TV compatible when the stand alone PSP games are by themselves, otherwise I would easily play this on my PS TV with no qualms. Really want to sink my teeth into these 2 PSP games and play all six games before 2018 but alas unless I buy a Dualshock 3. 

  • Same exact issue here.
  • Same problem.. It's so weird and annoying!!! 

    Ps: I also tried a dualshock 3.. same problem..

  • I know im a bit late but did you find a solution?
  • did anybody find a solution? im thinking on buying a ds3 but it seems it doesnt work either