PlayStation General
19 Jun 2008 05:16 PM
CheckMatey
By: CheckMatey

icon_email Send Message

NAT Type 2 Tutorial

240 replies

 

 

 

How to get a Type 2 (Open) NAT on your PS3


 

 

Having a closed or limited NAT on your gaming console will cause a variety of issues. The PS3 offers Type 3, Type 2 and Type 1 NAT results. These break down as follows:

Type 1 - Connected directly to the internet (no router/firewall). Should have no issues.
Type 2 - Connected through a router properly. Should have no issues.
Type 3 - Connected through a router without open ports or DMZ setup for PS3. Everything should function properly, but you may have connection, voice chat or other issues.
While most everything will function properly regardless of what your NAT setting is, your best bet is to set up your PS3 so that you can obtain a Type 1 or Type 2 NAT. Since most of us have routers at home for connecting multiple computers or devices to the internet, chances are the best we will get will be Type 2. Thankfully that's fine and everything will work properly.

If you have not adjusted your settings on your PS3 or router, chances are you have a Type 3 NAT and probably never knew it. With a few simple changes you too can have a Type 2 NAT. Order now for just $19.99. But wait, there's more.

The first thing you will want to do is check your network connection. Head on over to the Network Settings tab on the XMB. It looks like this:



Once there choose the Internet Connection Test item. It looks like this:



You will receive a warning letting you know that you will be signed out in order to perform the test. Choose okay. If you have not made any setting changes in your PS3 or Router, chances are you will receive the following message:


The warning reads: "When the NAT type is type 3, chat or the communication features of games may be restricted. For more information, refer to the online instruction manual."

If you run the test and have Type 2 or Type 1, stop fooling around and go play some games! If, however, you have Type 3, read on for help on opening up your NAT.

In order to open up your NAT on your PS3 you will need to make an adjustment on your PS3 and on your router. First you will want to set up your PS3 for a static IP address. This means turning off DHCP and assigning your PS3 a single, static IP address. Before you start this process head over to the network tab on the XMB and choose "Internet Connection Status." From here note your current IP address, your subnet mask, your default router and primary and secondary DNS settings. Write these down, you will need them in the following steps.

To do this, visit the Internet Connection Settings tab on the XMB. It looks like this:



From here most of the settings can simply be passed through with default settings. There are two areas, however, that you have to change. The first is choosing a Custom address setting (instead of Easy).



From here, you will want to choose Manual IP Address Setting:



Remember the settings you wrote down from your status page? You will need them here. You will have to enter in the static IP Address you want to assign to your PS3, the Subnet Mask (which is usually 255.255.255.0), the default router (the IP address of your router, most often 192.168.1.1 or 192.168.100.1), and the Primary and Secondary DNS settings. You will have to input all of these numbers. This is made much easier with a DVD Remote or keyboard.

Please NOTE - You will want to set the last number of your IP address high enough that other wireless or wired items on your network will not be assigned the same number through DHCP. While DHCP had chosen .3 as an IP address for my PS3 initially, I bumped it up to .23 because I have less than 23 items in my network. If you do not have DHCP enabled on your router, you do not need to worry about this and can simply choose an IP address that does not conflict with your other devices and which is available through your router.



Once you have all of the settings input, press X to save them. Your settings will change and the PS3 will offer to perform an Internet Connection Test for you. If you let it do the test now chances are you will still get a Type 3 NAT connection. Don't fret little bear, we still have one more step.

In addition to making the necessary changes on your PS3, you will also have to open up some ports on your router. The ports you need to open are:

 

 

Go to your default routers setting, By typing in your Routers IP in URL Box - linksys's default is 192.168.1.1 and Username is blank, Password is Admin

 

More Usernames and Passwords - http://www.phenoelit-us.org/dpl/dpl.html


TCP: 80, 443, 5223
UDP: 5223, 3478, 3479, 3658

I have a Linksys Router and my port forward settings page looks like this:



Depending on what type of router you have, your settings page may look different. In order to obtain an open or Type 2 NAT, you will need to open those ports listed above.

You can see in my screen capture that my PS3 is listed with its static IP address that I set above (.23) and that all of the necessary ports are forwarded to that IP address. The X listed items above (.24) are for my Xbox 360 so you don't have to worry about those.

Once you have forwarded these ports and saved your settings its a good idea to unplug and plug back in your router. This will refresh everything on your network connected to your router. Once done head back to your PS3 and perform an Internet Connection Test. If you did everything correctly you should receive the following page:

 

Turning off Media Sharing Improves connectivity so turn that off, unless you really use it.

 

If you still don't get NAT 2, You'll need to Bridge your modem with your router, contact your ISP, and Router manufacturer if needed.

 

LINKS HOW TO BRIDGE MODEM/ROUTER:

http://www.phoenixthesmeg.byethost16.com/howto/sss4200.html

http://www.dslreports.com/forum/remark,19554536?hilite=

Congratulations, your NAT is now setup and working properly!

Now this is only for Linksys but other routers use similar formulas and also if u enable DMZ or UPnP you might get NAT 2 Auto Matically!

 

I know there is couple out there but they seem to be lost or something, so here is a new fresh one!

 

 

Extra Info from you Forum Friends:

 

Assigning a static IP address to your PS3

 

In order to assign your PS3 a static IP address, you will need a few internet configuartion settings. To find these, you will need a PC.

 

 

1) Make sure the PC is on and connected to the same internet your PS3 will be utilizing.

2) Click the "Start" button on the bottom left of your screen

3) Click "Run"
4) Type: cmd

5) Click "OK". This will bring up command prompt, the window shown below

6) Type : ipconfig /all
7) A long list of words a numbers will then appear.



Write down the following information and keep it handy. You'll need it later!:

 

            Default Gateway
            DNS Servers (only the first 2)
            Subnet Mask
            DCHP Server

Thats all you need from the PC for now. Double check your numbers and make sure they are correct.

 

Credit to rosey14 for the Mini-Static IP Tutorial.

 

-

 

Quick summary:

 

(1) Alot of DSL subscribers still use PPPoE - you need to remove the username and password from the ISP provided router/modem combo...then add that information to your personally owned router.

 

There is other options too (turning your personally owned router into just a swtich; turning off DHCP and plugging the router/modem into a LAN port versus the WAN/internet port)

 

Credit to schu70 for the PPPoE Info.

Message Edited by CheckMatey on 06-19-2008 04:16 PM

  • Or YOU COULD simply buy this gaming router and u will always get nat type 2 in any connection http://www.geocities.com/samuelgoh21/WRT330N.jpg
    0

  • EVILEMPIRE wrote:
    Or YOU COULD simply buy this gaming router and u will always get nat type 2 in any connection http://www.geocities.com/samuelgoh21/WRT330N.jpg

    not true..as you can see from alot of the threads; DSL customers are more susceptible to "double NATing".  DSL companies are notorious for giving thier customers modem/router combo devices.  A modem/router combo(not bridged) connected to a router, creating a double NAT issue giving the NAT3 on the PS3 side.  No router is going to fix this senario...it's the modem/router combo creating the problem. 

    0

  • EVILEMPIRE wrote:
    Or YOU COULD simply buy this gaming router and u will always get nat type 2 in any connection http://www.geocities.com/samuelgoh21/WRT330N.jpg

    yes u prob could but maybe not all connections but not everyone can afford or feel like it like me i dont feel like it i like my linksys

    0
  • So I have tired this numerous times and it still doesn't work...any suggestions? I am thinking the modern/router combo is the affect i'm getting and have no clue on how to fix it.
    0

  • MarineSaunders wrote:
    So I have tired this numerous times and it still doesn't work...any suggestions? I am thinking the modern/router combo is the affect i'm getting and have no clue on how to fix it.

    check to see if you have a double NAT issue.  What is the external IP you router is getting?

    0

  • Punisher69 wrote:

    MarineSaunders wrote:
    So I have tired this numerous times and it still doesn't work...any suggestions? I am thinking the modern/router combo is the affect i'm getting and have no clue on how to fix it.

    check to see if you have a double NAT issue.  What is the external IP you router is getting?


    How do you check if you have double nat? And im pretty sure it is 192.168.1.1 could be wrong, its a linksys wrt54... also in theis guide it says you need 2 DNS servers and when I look up my info I only have 1.

    0

  • MarineSaunders wrote:

    Punisher69 wrote:

    MarineSaunders wrote:
    So I have tired this numerous times and it still doesn't work...any suggestions? I am thinking the modern/router combo is the affect i'm getting and have no clue on how to fix it.

    check to see if you have a double NAT issue.  What is the external IP you router is getting?


    How do you check if you have double nat? And im pretty sure it is 192.168.1.1 could be wrong, its a linksys wrt54... also in theis guide it says you need 2 DNS servers and when I look up my info I only have 1.


    thats the internal IP...go to the status page, that should show the IP the router is getting from the modem/router combo unit.

    0
  • Ahh ok the internal is 192.168.254.2....I just tried that one for the deafult router when hooking up a connection, didn't work at all.
    0

  • MarineSaunders wrote:
    Ahh ok theinternal is 192.168.254.2....I just tried that one for the deafult router when hooking up a connection, didn't work at all.

    External right? this is from the status page on your "router" and not modem/router combo right?  If it is from the status page then you have a Double NAT problem

     

    what does mean? I don't what you are trying to do there...

     

    0

  • Punisher69 wrote:

    MarineSaunders wrote:
    Ahh ok theinternal is 192.168.254.2....I just tried that one for the deafult router when hooking up a connection, didn't work at all.

    External right? this is from the status page on your "router" and not modem/router combo right?  If it is from the status page then you have a Double NAT problem

     

    what does mean? I don't what you are trying to do there...

     


    Yup that is the number from the status page of the router...

     

    Lol forget that part. 

    0
  • YAY! i got a KUDO!!!! OWNED!
    0
  • ROSEY14

    icon_email Send Message

    Very very nice, clean thread.

    We've been needing one of these for quite some time now. 

    0

  • rosey14 wrote:

    Very very nice, clean thread.

    We've been needing one of these for quite some time now. 


    yea thx so amny people comnig to ps3 and since 80gig came back alot of newbies so we needed one to help em get started!

    0
  • ROSEY14

    icon_email Send Message


    CheckMatey wrote:

    rosey14 wrote:

    Very very nice, clean thread.

    We've been needing one of these for quite some time now. 


    yea thx so amny people comnig to ps3 and since 80gig came back alot of newbies so we needed one to help em get started!


    Yes, very true.

    We really need it, with all the people asking questions, haha. 

    0
  • ROSEY14

    icon_email Send Message

    One thing you might want to add.

    You make it a little unclear on how to assign a static IP, and how to find your internet configuration.

    You may want to add this in:




    Assigning a static IP address to your PS3

    In order to assign your PS3 a static IP address, you will need a few internet configuartion settings. To find these, you will need a PC.

     

     

    1) Make sure the PC is on and connected to the same internet your PS3 will be utilizing.

    2) Click the "Start" button on the bottom left of your screen

    3) Click "Run"
    4) Type: cmd

    5) Click "OK". This will bring up command prompt, the window shown below

    6) Type : ipconfig /all
    7) A long list of words a numbers will then appear.



    Write down the following information and keep it handy. You'll need it later!:

     

                Default Gateway
                DNS Servers (only the first 2)
                Subnet Mask
                DCHP Server

    Thats all you need from the PC for now. Double check your numbers and make sure they are correct.
    Message Edited by rosey14 on 06-17-2008 10:50 PM
    0
  • Hi there,

     

    I just got my PS3 and i am having the same issues with the Type 3 NAT. I have an AirPort Extreme router. I was wondering if you know of the settings that I need to change (or how to change them)? I went through the tutorial and tried to apply the same settings as you did, but still no luck.

     

    Any help or know where I can find the answer?

     

    Thank you. 

    0
  • Ill keep this thread live for as lnog as i cna i need your help guys im really busy ty
    0
  • Jar_Jar

    icon_email Send Message


    MarineSaunders wrote:

    Punisher69 wrote:

    MarineSaunders wrote:
    So I have tired this numerous times and it still doesn't work...any suggestions? I am thinking the modern/router combo is the affect i'm getting and have no clue on how to fix it.

    check to see if you have a double NAT issue.  What is the external IP you router is getting?


    How do you check if you have double nat? And im pretty sure it is 192.168.1.1 could be wrong, its a linksys wrt54... also in theis guide it says you need 2 DNS servers and when I look up my info I only have 1.


    i have been workin with this gentleman via pm's on the forums  and from what i understand is  he has a speedstream 5200 modem which has usb and rj45 connectors  now he was talking to me on a computer that was connected to the usb and he told me he had the rj45 connected to the linksys router ,then to a second computer and the ps3  now i think that is where the problem lies i couldnt find info on it being a modem/router but i believe the 2 connectors on it share the same ip address, now what i would do is diable or remove the dialup connection on the computer directly connected to the modem  ,go on the router, go to the set up page for connection type ,click the pull down window and select pppoe  ,it will now have option to put  username and password  (usernaname and password  given to him by his isp)  set the option keep alive  and at the bottom  click save settings  (otherwise the router wont accept the changes)  now power cycle modem and router and any computers/ps3 connected on the router side  and (without the computer connected directly to modem) and see if you get connected with 2nd computer and ps3  if ps3 still nat 3 ,dont worry there are still settings on the router you can change , now if you can connect to the internet successfully move the first computer to the linksys and power it up  and like i said earlier if this is the computer with the dialup info it has to beeither removed or disabled because the login is now done by the router!         i put this here   so  you can pick it up since i missed your pm this afternoon  and so these other guys helpin could see the setup

    0
  • yea we got 2 kudos
    0
  • Smokey

    icon_email Send Message

    Good post (detailed) but topic has been thoroughly covered by many others.  Do a search on NAT2 and you will find alot of good threads on NAT.  Also like another poster mentioned you might want to add the DSL (router/modem) resolution as well.

     

    Here is a thread ballman77 started with a few good links and posts from others.

    0

  • schu70 wrote:

    Good post (detailed) but topic has been thoroughly covered by many others.  Do a search on NAT2 and you will find alot of good threads on NAT.  Also like another poster mentioned you might want to add the DSL (router/modem) resolution as well.

     

    Here is a thread ballman77 started with a few good links and posts from others.


    ill see if i can do something bout the router/modem thing

    0
  • I added soem info!
    0
  • Smokey

    icon_email Send Message


    CheckMatey wrote:

    schu70 wrote:

    Good post (detailed) but topic has been thoroughly covered by many others.  Do a search on NAT2 and you will find alot of good threads on NAT.  Also like another poster mentioned you might want to add the DSL (router/modem) resolution as well.

     

    Here is a thread ballman77 started with a few good links and posts from others.


    ill see if i can do something bout the router/modem thing


     

    Quick summary:

     

    (1) Alot of DSL subscribers still use PPPoE - you need to remove the username and password from the ISP provided router/modem combo...then add that information to your personally owned router.

     

    There is another option too (turning your personally owned router into just a swtich; turning off DHCP and plugging the router/modem into a LAN port versus the WAN/internet port)

    Message Edited by schu70 on 06-18-2008 02:07 PM
    0
  • ober777

    icon_email Send Message

    I went home last night and check the Type setting on my PS3 and it said it is Type 2.  Funny thing is that I didn't open up any ports on my WCG200 linksys g gateway/router/modem.  very odd indeed.

     

    should I still go ahead and open up the ports?  I was playing motorstorm last night and I wasn't sure if people were talking or not ... I see their name in the upper left hand screen.

    0
  • ahh prob UPnP DMZ and u should for max connection
    0
10 pages